Renderer Overview

Renderizador

Selecione as definições desejadas para a renderização no Controles, Opções, Definições, e Raytrace . Pressione o botão Render para iniciar o processo.

Por padrão é usado o renderizador por "Scanline". Vários níveis de Raytrace podem ser aplicados noPainel Raytrace, lembre-se que Raytrace consome mais memória do que Scanline.

Note Renderiazação de teste pode ser feita rapidamente com o comandoArquivo > Renderização rápida (F12) a partir do Animador ou do Designer.


Render Control Tab Page

Renderizador OpenFX

Resolução - Escolha a resolução. Vc pode escolher de uma das pré-definições ou digitar o número de "pixels" para a imagem.

Anti-serrilhado - Escolha essa opção para definir o nível do anti-serrilhado. Basicamente anti-serrilhado suaviza o contornos dos objetos na renderização de forma a disfarçar os "pixels". Quanto maior o nível, maior o tempo de renderização.

Acelerar o Anti-serrilhado - Pode provocar resultados insatisfatórios. Experimente, se o resultado for bom para a imagem que vc está usando ele pode diminuir consideravelmente o tempo de renderização.

Misturar cores - Escolha o tipo de mistura que na verdade é otimização da paleta da imagem, imagens de 24 bit não precisam de mistura. Já imagens de 256 cores sim, essa é uma forma de evitar o "Banding" (cores num degradê quebradas por exemplo).

Há vários métodos de mistura. O "Floyd-Steinberg" é mais apropriado para imagens estáticas. "Noise Dithering" é mais apropriado para animação.

Formato da imagem - Selecione o formato. Isso irá determinar a paleta de cores automaticamente. GIF usa um formato de 8bits, TGA e TIF 16 bit ou 24 bit.

Tipo da animação - Selecione o formato.FLIC (256cores), AVI (padrão Windows), ou GIF animado (256cores). Note que arquivos FLC não possuem compressão se a resolução for maior que 640x480 "pixels".

Nome da imagem - Nome da imagem e pasta onde será gravada. Pasta padrão é "Render".

Nome da animação- Nome da animação e pasta onde será gravada. Pasta padrão é "Movies".

Quadro atual - Especifica qual quadro da animação será renderizado.

Alcance - Especifica um número de quadros que será renderizado.


Render Options Tab Page

Opções do Renderizador

Linha oculta - Renderiza a imagem desconsiderando as faces e arestas atrás dos modelos. Acelera a renderização.

Reflexo do solo com anti-serrilhado - Para reflexões do solo sem Raytrace.

Sem suavização - Desconsidera a suavização das faces e renderiza todos os cantos. Acelera a renderização e é possivel que ocorra desativação de algum mapeamento.

Reduzir Saturação - Pós-processo que remove cores 'ilegais' para o formato NTSC.

Escrever GIFs entrelaçado - Grava os GIFs no modo entrelaçado. O formato será o GIF 87.

Solo no canal alpha - Cria um alpha com o solo na imagem.

Escrever arquivo alpha separadamente - Escreve um arquivo alpha para cada imagem. Solo não está incluido.

Use armazenamento da tela cheia - Renderiza todos os "pixels" para um "buffer" de memória antes de cria o arquivo temporário. Ele aumenta a velocidade do Renderizador e imagens de Pós-processo requerem isso. Por outro lado exige um número alto de memória RAM.

Armazenamento Z - Cria um "buffer" com informação da profundidade da imagem. Use-o se a animação usa um pós-processo como neblina que requer essa opção ligada.

Usar armazenamento do ID do ator - Cria um "buffer" para o processo externo que identifica qual ator está visível na imagem final.

Exibir imagem enquanto renderiza


Render Settings Tab Page

Definições do renderizador

Velocidade da animação - Define a velocidae para arquivos FLI/FLC. O Valor é em unidade "jiffies", zero faz a animação rodar o mais rápido possível.

Ângulo da suavização

Luz ambiente % - Substitui a luz ambiente especificada no ator Atmosfera. Um máximo de 30% trabalha bem, valore maiores que 70% produz imagens com alto contraste.

Densidade da sombra % - Especifica a escuridão das sombras lançadas no solo. Define a densidade da sombra. 50% é o padrão, 100% produz sombras completamente negras, 0% não aparece sombra.

Armazenamento da Luz Spot - Altera a resolução das sombras lançadas pela luz. As sombras lançadas exigem memória. Um valor de zero impica que a luz não lança sombras. Vc pode calcular definições para resultados melhores multiplicando o número de "pixels" por 4 (isto é 320x200x4=256,000 bytes requiridos).

Ângulo da linha de ilustração -Ângulo máximo para as faces planas no modo Ilustração. Se duas faces são adjacentes e o angulo entre elas é menor que este valor o contorno não será desenhado. Um alto valor resultará em apenas um contorno no modelo na imagem, que pode ser útil para imitar o estilo "Cartoons" para desenho animado.

Valor do Ruído - Granula a imagem.

Desfoque de movimento - Valores altos geram desfoque de movimento. O alcance normal é 0-10. Quando um número fora desse alcance é definido a integração do desfoque inicia.

Dígitos nos nomes dos arquivos - Especifica o número do quadro no nome do arquivo renderizado.

Qualidade da imagem JPEG - Especifica a qualidade da compressão JPEG. Qualidade alta cria arquivos de grandes tamanhos.

Especificar números de processadores - Ativa seleção de 1-16 processadores ou coloca o renderizador automaticamente para determinar o número de processadores e atribuir a cada um trabalho.

Definições pessoais - Gravar e ler definições personalizadas.


Render Trace Tab Page

Raytrace

Opções para renderização utilizando Raytrace.

Traçar sombras - Todas as sombras são automaticamente calculadas.

Traçar reflexões - Todas as superfícies reflectivas autmoticamente são calculadas.

Traçar refração - Todas as superfícies com refração autmoticamente são calculadas.


Ray Tracing Parameters

Parâmetros do Raytrace

Introdução

Esta página explana a ação de otimização e a informações sobre o processo de renderização por Raytrace.:

As definições são:

  • Otimização básica ou total
  • Profundidade
  • Percentual mínimo
  • Tamanho

As informações reportadas (listadas abaixo) são muito úteis para fazer renderizações subsequentes mais velozes.

  • F = (Número de faces na cena)
  • V = (Número de vértices na cena)
  • Dp = (Máxima profundidade)
  • Th = (Número alvo de faces atribuídas por voxel)
  • F/V = (Número máximo de faces atribuídas no algorítimo de otimização por voxel)
  • Size = (A [máxima(e mínima)] dimensão (em unidades internas) de cada voxel criado com a otimização)
  • Vx = (Número de voxels criados com a otimização)
  • Fc = (Número total de faces atribuídas feitas por voxel na subdivisão espacial)

Alguns termos usados acima podem não ser familiares a vc mas para otimização dos parâmetros vc precisará entendê-los para melhorar o tempo e cálculo permitindo que cenas com muitos polígonos sejam renderizadas.

Os conceitos básico do algorítimo do raytrace serão abordados nessa seção e então nós consideraremos a otimização em questão.

O algorítimo Raytrace

Raytrace pode ser um procedimente lento mas atribui as imagens renderizadas qualidades fotográficas soberbas. Muitos livros descrevem em detalhe o processo e também programas opensource mostram e ensinam o processo. Um dos mais compreensíveis é o POV-Ray.

A idéia onde o Raytrace é baseado é algo simples de entender como segue:

Seguindo o caminho percorrido pelas "partículas de luz" (fótons) na sua jornada entre a origem da luz até a cena (onde elas são refletidas ou atravessam e são desviadas por objetos transparentes) até serem capturadas pela câmera ou lançadas ao infinito.

Depois desse poema, na práticas o Raytrace tenta imitar essa emissão de fótons com se eles fossem raios, então ele calcula a fonte de emissão até seu destino e ao encontrar objetos na trajetória esses raios podem ser desviados (no caso de superfícies refletivas) ou divididos (no caso de superfícies refratárias como o vidro) seguindo assim uma nova trajetória até a situação se repetir. Só por aí vc já pode perceber quantos cálculos matemáticos o processador tem que fazer para calcular a iluminação.

O algorítimo padrão para o Raytrace possue basicamente 5 passos:

  • Ler os dados que descrevem os objetos na cena e carregá-los na memória.
  • Mover cada modelo para a posição determinada.
  • Aplicar as transformações que a vista exige.
  • Calcular a direção do raio.
  • O raio é seguido (traçado) até interceptar um polígono que dependendo das propriedades de sua superfície determina a cor aproximada do pixel que o representará na renderização final.

O raio será calculado e desviado até o destino final ou sua atenuação.

Portanto quanto mais elementos na cena mais o tempo para o cálculo da mesma. O tamanho final da imagem renderizada também influencia no cálculo.

Para se ter uma idéia do tamanho do cálculo: para fazer uma imagem de 640 por 480 pixels usando um valor de anti-serrilhado de 2 numa cena com 20.000 polígonos serão gastos 24 bilhões de testes.

Para reduzir o tempo de cálculo a técnica usada chama-se otimização.

Otimização

Normalmente requer 2 modificações para o algorítimo Raytrace:

  • O passo de avaliação da cena deve ser feito antes da renderização.
  • A avaliação da cena é usada para reduzir o número de polígonos que precisam ser testados antes do raio passar de um ponto a outro.

Existem 2 aproximações apropriadas que precisam ser investigadas:

  • Volumes limitados
  • Subdivisão espacial

O renderizador usa uma subdivisão espacial parecida com:

A idéia básica é dividir o espaço em um número de cubos que contém poucos polígonos dentro deles. Quando os rais são traçados atravessam a cenas de cubo em cubo e quando encontram um polígono é checado em qual direção o raio foi refletido em relação ao cubo. Então quanto menos polígonos conterem cada cubo mais rápido será o cálculo (em termos técnicos cada "cubo" será conhecido agora em diante como "voxel").

Uma ilustração bidimensional mostra o princípio, ela mostra a coleção de objetos e um série de retângulos que divide a região onde cada objeto ocupa, veja que somente um objeto está em cada retângulo:

sfxtut1_0.JPG (22203 bytes)

Oitavas

O passo de otimização inicia-se calculando o volume do espaço ocupado por todas as faces na cena para criar um cubo limitado que envolve todas as faces na cena. Se esse cubo possuir mais que o número mínimo de faces é dividido em outros 8 volumes menores. Esses volumes filhos são checados e se ainda não satisfazerem o limite de faces são divididos de novo em 8 volumes menores, e assim sucessivamente. Esse processo é chamado Oitavas.

Veja a ilustração:

sfxtut1_1.JPG (17417 bytes)

Em termos hierárquicos o esquema será:

sfxtut1_2.JPG (26697 bytes)

Os números dentro dos círculos representam o número de faces dentro de cada cubo e o nó associado. Vc percebe que a subdivisão é refinada quando o valor de faces é muito alto.

Sendo assim, cada parte do raio segue pela cena e move de cubo a cubo e somente um máximo de 10 faces para cada cubo é testado. Um grande tempo reduzido no cálculo.

Assim vc poderá entender a informação reportada da cena, onde: (F) é o número de faces na cena, (Fc) quantas faces foram colocadas em voxels. Assim, se Fc=F nós temos uma perfeita situação de 1 para 1 e o cálculo será muito rápido.

Os parâmetros

  • Otimização total ou básica. Use a básica quando a imagem final for pequena e a total quando for em alta resolução com o melhor anti-serrilhado.
  • Profundidade determina o máximo de camadas de subdivisões da Oitavas. Determinando um valor o OFX não subdivirá "eternamente" principalmente se a imagem não requer tanto detalhe.
  • Percentual mínimo é relacionado com o número de faces atribuídas a cada voxel. O ideal é um ou 2, mas para cenas com modelos mais complexos um valor bom é 9 ou 10, entre 100 e 150 também é possível. Novamente veja os valore reportados para (F/V) e (Fc) para definir a melhor opção.
  • Tamanho controla o tamanho mínimo do voxel. Sua escolha depende das dimensões do modelo nas unidade internas. O valor padrão é ideal. Para modelos que possuem um tamanho muito grande, um tamanho maior aumentará o processo de renderização. O tamanho reportado ajudará vc refinar suas definições.

Referências

[1] Practical Ray Tracing in C / Book and Disk (Wiley Professional Computing) by Craig A. Lindley


Quick Render

Renderização rápida

Clique direito na vista Câmera e escolher Renderização rápida ou usar F12. A renderização mostrará, mapeamento, texturas, reflexos, etc.

Note que a opção no menu não estará disponível se o recurso Sombreamento via OpenGL estive ligado.

Dica: Renderização rápida será mais rápida se o monitor estiver no modo 16 milhoões de cores.